CCEDK trading pairs - other exchanges need to follow


Line 558-559 in your repo ( ) are currently reading this:

                    if unit['pair_name'][:4] == 'nbt/':
                        self.pair_id[unit['pair_name'][4:]] = unit['pair_id']

change them to this:

                    if unit['pair_name'][:7] == 'us-nbt/':
                        self.pair_id[unit['pair_name'][7:]] = unit['pair_id']

Is that what you tried? Note the 7’s. This will probably require everyone to update their client.

1 Like

Tried without changing both 7s. Thanks a lot for that. Have been wrestling this for hours.

Server is back up and running now, had some spontaneous issues with supervisor rights etc. possibly due to the backups but all solved. PyBots for Bittrex and Poloniex are up and running again.

However I’m still unable to start on a CCEDK trading pair. The message is:

ERROR: Unable to receive balance for NBT on CCEDK: exception caught: ‘nbt’

The odd thing is that apparently at least one person has figured out how to make it work as is submitting an USD balance. I’ve changed both on the server and locally for the PyBot.

Any thoughts what else to change?

Have been successful trading on NBT/BTC pair after some changes in on the client side. However the Bittrex and Poloniex PyBots stopped. Need to separate out bot operation on different machines. Will need some more testing.

Edit: moved Bittrex and Poloniex bot to a different VM. Up and running, however seeing bad performance/efficiency on both Bittrex and Poloniex PyBots on one VM and BTC/US-NBT and USD/US-NBT PyBot on another VM…SOLVED. Will have it running for a while to see whether it stabilises. Still having issues with EUR/US-NBT Pybot, but might be another problem…SOLVED.

Just published the required changes to support US-NBT on CCEDK with PyBot in a new release on Github here:

Instructions to update existing installation:

  1. Unzip release
  2. Copy and to the folder where your PyBot software resides. Choose overwrite when asked.
    On Linux, this is usually in your folder under nu-pool in the folder Python.
  3. Restart Python, the easiest and surest way to do this is to restart your PC. This is required to remove the cache and load the new files.

... ERROR: unable to receive balance for nbt on ccedk: exception caught: 'nbt'
on a ubuntu box

Complimentary comments: If this were a Fixed Cost pool, i would have very strong mottivation to try the fix and get it to work ASAP because if I am the only one providing the liquidity I will get all the reward.


Does work, when sending there nubits and withdrawing BKS?

I can’t say so for the US-NBT pair, but when it was NBT, it worked.
That’s how I tested (funded) one of the BKS multisig addresses, which was created for the NuSafe collateral.

1 Like

The error is typical when you only apply changes to which is inadequate.
Did you also take the updated from the new release? In there, there are 3 mandatory changes and 2 text changes to reflect the conversion from NBT to US-NBT on CCEDK. Besides that a restart of Python service is likely required as some caching mechanism gets in the way.

Edit: reviewing release, something might have gone wrong with update, please hang-on.

Right, for some reason not all changes made it in to release 1.5LB. Have now update the repo manually and renamed it to 1.5.1LB. It can be downloaded here:

Please note that this release can only be used on CCEDK until the other exchanges have also applied the changes from NBT to US-NBT. If you like to continue using other ALPs then make sure you save this release in a different folder and make changes to the bots to reflect the different startup folder.

More information regarding the installation process can be found here or please let me know if you need assistance in this forum or here on gitter:

Now clients are working placing orders. But…
the spread is much higher than it is defined with “offset” parameter. In fact this parameter is not working at all!

Moreover CCEDK has a problem after placing orders, the column “Funds into the orders” under “My Funds” remain zero! @ronny

the nbt/btc exchange on ccedk is having a problem matching orders @ronny