[Passed] LiquidBits term 7 grant (updated) - Automatic Liquidity Pool (ALP)

I’m aware that this already creates a lot of efforts, but…
…could this be an opportunity to make a hard cut over to ALPv2?
I mean, the ALP clients need to upgrade, because of the changed CCEDK API, right?

A properly scheduled and announced change would be way better.
But it seems that it’s already too late for that.

Mh. There are orders on the books and the pair ID’s on the public API haven’t changed, just the names.

I’m not sure what to think of that.

It has me puzzled too. The server has been down for 12h now. They haven’t been cancelled clearly. Doing another attempt to revive the server before I have to attend to other commitments for most of the day.

It is not that it is ready to fly, had planned to look into it over Easter. It will need to be tested and understood before it runs safely and secure. I’m not a developer and not a full-time system administrator. It will take time.

Edit: it is unclear what is going on, just did a full restore from a backup one week old. I’m unable to start the server.py successfully for CCEDK or Bittrex/Poloniex. The PID runs but there is no logging output and its bots can’t see it. This is really weird. I’m running out of options. Will make another attempt tonight with an even older backup.

The services has been restored after the issues with the change from NBT to US-NBT to CCEDK. However an upgrade of the software is mandatory to continue using PyBot on CCEDK.

Existing users, see for a quick update here:

Details for a complete upgrade are on the website here: http://cybnate.github.io/index-liquidbits.html#Instruction_for_installing_and_using

1 Like

I can’t make it work on windows 7.
I am getting the error: unable to receive balance for nbt on ccedk.
I have removed old python installation 2.7.9, perform a restart and install the new python 2.7.11
Has anyone succeeded?

The release appeared to be incomplete, made an post here about the problem. CCEDK trading pairs - other exchanges need to follow

CCEDk changed US-NBT to USNBT. does the client need to be changed?

I haven’t checked the API, but I recognized the change on the website as well.

If it does require a change, don’t forget to change the number of characters in that one line in utils.py and the line after it.

I asked CCEDK to remove the ‘-’ between the US and NBT as someone else asked coinmarketcap.com (CMC) to use the USNBT denomination instead. I hoped that this change would make CMC recognise CCEDK and the BKS market again. This doesn’t appear to be the case though. I’m intending to contact CMC about this unless someone PMs or asks me in this thread not to or is already taking care of this.

Re API; I asked CCEDK to not touch the API or inform us if required. The change can be made reasonably quickly if needed, but I haven’t encountered any problems yet even after a restart of Pybot where that was the case with the previous change. Please let me know if you encounter problems and I will test and make the change asap.


my client as been stuck in the beginning with no output. When pressing ctrl-c it says the config file couldn;t be read, an error that happened before and was found associated with reading ccedk time-out.
Any clue?

Looks like we need to change the API with CCEDK again from US-NBT to USNBT
Will publish a new release and restart the server after next payout.

Edit: new 1.6 release published: https://github.com/Cybnate/nu-pool/releases

This version still doesn’t work. but I figured it out

in exchange.py this

if unit[‘pair_name’][:7] == ‘usnbt/’:

should be

if unit[‘pair_name’][:6] == ‘usnbt/’:

“6” is the number of characters in 'usnbt/'. It was 7 but should be 6 now. I don’t know how everyone else’ client could have worked.

The code really should have better debugging info to show trace of execution.

Could have helped me there. Oh it did register in my mind and helped.

1 Like

Thanks, because of that problem it also took a bit longer to get the server restarted.
All running again by now.

And published release 1.6.1 with the error corrected: https://github.com/Cybnate/nu-pool/releases

As long as you don’t restart it, it continues to work. With the server restart everyone needs to update.

1 Like

A while ago the NuRPC and the server.py became detached for an yet unknown reason. Therefore the by LiquidBits provided liquidity is no longer (correctly) broadcast on the network but still available on the exchanges. The only way to fix the broadcast is to restart the server.py and Nu. I will do that after the next payout around 7.40am UTC to minimize the impact on the payouts.

The restart didn’t work, the Nu daemon was still not able to broadcast.
Updating the blockchain to Nud v2.11 now. This may take a while.

The broadcasting is still not working. Anyone any idea what might be causing this:

2016/04/10-12:05:41 ERROR: NuRPC: unable to send liquidity: Failed to process info.

Does nud respond to rpc commands? Can you getblockcount and sfuff?

Problem has solved itself after nud v211 upgrade. It did accept the unlock wallet account RPC command yesterday, haven’t tried anything else after that. Will keep an eye on it.

There are still issues with the LiquidBits server. I’m unable to place orders on Poloniex and Bittrex although the PyBots believe all is fine. Orders on CCEDK are fine, but the automatic payout didn’t come through. Apparently there are some Cloudflare issues affecting this and other operations. I’m sitting it out until it is clear what is going on before reverting back to a backup tomorrow if it doesn’t resolve itself.