NuShares dividend address


maybe this is a dummy question that could have been prevented by having read the f*cking manual first, but… as there’s no manual (and I need to admit that I haven’t read the whitepaper so far):
how can you adust the Peercoin address that is used for dividend payment?
Wouldn’t it be good to have a chance to own the address that is used for dividend payment?
This might sound stupid, but I didn’t find a way to do that…

Kind regards

Not a stupid question. I’ll try to answer it the best I can (and if I misrepresent anything, please speak up):

You don’t. The peercoin address that is paired with your nushares address for dividends is essentially the same address, just translated into the Peercoin format. So you control the private keys for it.

It’s yours, no one else can access it, unless they have access to your private keys for your nushares address.

You import it into your Peercoin wallet to transfer ownership using an automated command “Export peercoin addresses” or from the command line.

Now I feel for sure a bit stupid, although the question might not be that stupid; I should’ve known better :wink:
Thanks for the explanation!
Seems I need to find out how to export the keys from the Nu wallet to import them into the Peercoin wallet, if I want the Peercoin dividenends to end up in my Peercoin wallet…

I’ll include instructions here, but then point to the wiki page once it has been added there.

Instructions for how to set up your connection between Peer(coin/unity) and Nu

  • Make sure that for both Nu and your Peercoin wallet client that you have a configuration file available, and that each has at a minimum the following information. (Your Nu client should already have this because you needed to include it to connect to the network directly). If you need assistance, please let CG, Penny, or I know and we’ll get you set up.

  // for use on the testnet, include `testnet=1`
  • Once the configuration files are in place, launch both clients.

  • After the networks have done their respective synchronizations, open up the debug window in your Peercoin wallet from the file menu: Help > debug window. Next, select the “Console” tab and in the input at the bottom, enter the command to unlock your wallet (not just for minting, but for all operations):

walletpassphrase <passphrase> <timeout>

// for example: `walletpassphrase sparkles 600` = unlocks the wallet for 10 minutes
// if your password contains special characters or spaces, make sure to wrap it in quotes (ex. "SupR@")
  • After you have unlocked the Peercoin wallet, go back to your Nu wallet and change your units to work from the NuShares side (file menu: Unit > NuShares).

  • From the file menu: Shares > Export Peercoin keys

  • If everything works as expected, you will see a dialog appear with a count of the number of addresses that have been exported. You can confirm this action by viewing your Peercoin wallet and looking on the “Receive Coins” tab. There should be a number of new addresses with the label “NuShares” that match the number that was exported in the previous step. If you do not see this, please make sure that your wallet was unlocked (and not just unlocked for minting) and try it again.

In your Peercoin wallet client, on the Receiving tab, you will see that the NuShares dividend addresses have been included:

Once that has been completed, you’ll be ready for a dividend distribution. If you should add additional NuShares addresses in the future, please make sure you follow the same steps again to integrate those new paired keys into your Peercoin wallet. You will not duplicate existing keys, so this operation can be run as many times as you need, into the future.


0 key(s) were exported to Peercoin

If you see a dialog like this, when you try to export the keys:

The most likely situation is that your Peercoin wallet is not unlocked, or, that you could have unlocked it, but only for minting. You need to make sure that it’s fully unlocked using the walletpassphrase command listed above. Using the unlock for minting only button or command WILL NOT WORK.

Port conflicts

If you experience problems with connecting the two wallets, please confirm that your network allows traffic on the following ports:

RPC PORT  14001     // Base RPC port used by the NuShares RPC server. Other unit RPC servers listen on RPC_PORT+1, RPC_PORT+2, etc.
RPC PORT  14002     // NuBits

// Same rules apply to testnet, but on different ports
TESTNET RPC PORT  15001     // NuShares
TESTNET RPC PORT  15002     // NuBits

// Peercoin ports used when communicating with the Peercoin wallet for dividend distributions

Ben, could you please explain more about the configuration file: what is it likely to be named, where is it, and how do we know if we have one?

The files are located in the “Roaming” folder on Windows. You can find it by typing %appdata% while searching programs. There should be a folder named appropriately for each crypto wallet you have. In the folder you should either find a .conf file or you can make one.

I’ll pretend that said TomJoad. Here’s the guide for Windows users:

Step 1: Open your computer’s control panel. Type in “Show hidden files and folders”. Click the option that comes up.

Step 2: Click the option that says “Show hidden files, folders, and drives”

Step 3: Go to C:/Users/YOURNAME/AppData/Roaming/Nu/ . You should see a file named nu.conf. You’ll see ppcoin.conf in the same place in the Roaming/PPCoin folder. There shouldn’t be any need to modify this file, but you’ll see it’s there.

I think I need some help. Having done all of the above, I’m getting this message:

Ports are standard (as above). rpcport=9902 (Peerunity) Using peercoin.conf and not ppcoin.conf
RPCuser and password set. Should they be identical or not?. Tried both to no avail.
rpcallowip= is on
server=1 is on

Stopped and started client several times to ensure that changes in config are picked up.
Is it a Peerunity issue? Anyone successful with Peerunity?

I’ve just been successful with Peerunity despite a previous error. On linux I got the error that all my Nushare addresses were invalid (which caused a worry for a moment or two).

The rpcuser and rpcpassword do need to be the same in bot the ppcoin.conf and nu.conf files.

Thanks for your reply. Makes sense, but getting a bit desperate as it still doesn’t work. Will try with standard wallet tomorrow, getting late here.

No need for stress. We’ll get it to work.
When you’re ready could you post the rest of your nu.conf and ppcoin.conf files (blank out the important passwords etc. of course)

I have ppcoin.conf ONLY.
I don’t have nu.conf at all.
i have successfully parse the ppc keys :wink:



@Cybnate , why are you using a file called peercoin.conf, rather than ppcoin.conf? I just checked my Peerunity machine and confirmed it is running correctly with ppcoin.conf.

Nu is looking for that file.

Also, there is no need to panic. Dividend distributions occur in the blockchain; not to individual wallets. No one misses out if they haven’t imported their keys, you just won’t be able to access the funds in the different addresses that you were paid into until you’ve told your Peercoin wallet that you are the rightful owner of the coins.

My Nu wallet is failed to connect with ppc rpc server. any help?

Now getting this error message “Error: incorrect rpcuser or rpcpassword (authorization failed)” any help?

I got briefly confused on that one, so thanks for confirming it should be ppcoin.conf. Already had synchronised both files just to cancel that out. However it is still not working

Could this have anything to do that I’m running Peerunity from an alternative datadir? I’m starting it with: F:\AppData\Roaming\Peerunity\peerunity.exe -datadir=f:\appdata\roaming\Peerunity. My .conf files are in that folder and not in a user folder on the default C:\ drive. Same for Nu. Does Nu assume a standard folder for the export, or assumes %appdata%?

Getting same problem here with peerunity.

Finally working.

Care to say what you did change to make it work?

What did you change, @nubitsbd?