NuShares dividend address

my nu rpc was 9902. I think that was the problem.

I changed it to: 14001

How many ppc will be distribute as dividends on 21st november?

How I’ll check it?

@Cybnate we’ll need to get confirmation from @sigmike or @coingame about running Peercoin from a non-standard directory.

I think I remember that before release when we ran larger-scale testnet dividend simulations you had it working. Did you change anything since then?

Yes, but probably went with standard client settings at the time, to deliberately exclude any issues with that.

Let me look through the configuration commands to see if I can find anything that suggests you can point to a different PPCoin directory.

Update: I don’t see anything explicit in the code or the docs.

Ok, I got it to work, by stripping down the peercoin.conf to barebones. So probably something silly or a complex interaction with one of the other settings I had in my ppcoin.conf. Don’t have the time to try again with different settings now.

I think it proofed at least that Peerunity with different settings can work.

BTW It took a few minutes for a single core to import those keys (more cores are not recognised). Both Peerunity and NU client were locked/not responding for a couple of minutes during the import.

This happened to me as well, but aside from that I had no problems.

Can’t find any nu or ppcoin .conf file on ubuntu, not even in the .config folder, can someone help ?

maybe we should specify that is not created by default .
You need to create one and place it there.

You have to make these two file.

@desrever @nubitsbd
I have created nu.conf and ppcoin.conf in nu and ppcoin folders, However when i try to export the keys this Error appears every time:

Error: You must set rpcpassword=< password> in the Peercoin configuration file:
If the file does not exist, create it with owner-readable-only file permissions.

I have to admit that i don’t know what is the rpcuser or the rpcpassword so i just used my ubuntu username and password since the wallets have no usernames, i even tried to write them with and without curly brackets, rpcuser=xxxxx or rpcuser={xxxx} , nothing worked!

How did you create them? I’ve seen problems if the operating system thinks that the files are .rtf or .txt instead of .conf

I have created a new empty document and renamed it to ppcoin.conf , in properties it says that the type is plain text document, but the original .conf files for other softwares in the .config folders also have the plain text type in their properties.

Have you tried to update the permissions of the .conf files, as mentioned in the error message?

$ sudo chmod 0400 ~/.ppcoin/ppcoin.conf; chmod 0400 ~/.nu/nu.conf

I have just did, the same Error appears.


Please clear out anything in the files already and then copy these lines into each of your .conf files (ppcoin.conf and nu.conf). You can update them after, for security, but initially let’s make sure it’s working with a known set of values.

server=1 rpcuser=test123 rpcpassword=abctest123

That is all you need to put in the file, for the basic operations.

It didn’t work at first, but after restarting the laptop it worked fine, Thank you

1 Like

My dividend received. thank Kiara.

1 Like

You can specify the peercoin config file to use with -peercoinconf=path/to/peercoin.conf.

Would it be possible to just put a peercoin wallet into the nu client?