Nu 2.0 qt won't boot up

After installing Nu 2.0, I am getting a runaway exception at bootup.

EXCEPTION: NSt8ios_base7failureE
CDataStream::read() : end of data
…nu.exe in Runaway exception

Anyone with the same issue?
Any easy fix?


Tks for the pointer
Deleting blk0001.dat and blkindex.dat did not solve the problem.
In fact, I found out that the culprit seems to be walletS.dat .
I copied the original walletS.dat into the roaming folder of a client (different machine) that has Nu 2.0 running fine. It caused the same error.
Copying the original walletB.dat did not cause any error.

Very weird.

I tried with several copies of the original walletS.dat to see if the copy was not compromised. It caused the same error.

Any clues about what is going on here?

WalletS.dat should be usable across the different versions, right?

Absolutely. Have you recently moved that file or done anything to the directory that it “lives” in? Can you check to see if it works with a pre-2.0 build?

Well very recently I have played with Tor.
I also encrypted walletB.dat and walletS.dat a few days ago.

So I do not think I disrupted the folder in a bad way.

Right now, I am reverting to nu-1.2.0 though I had to delete blk0001.dat and blkindex.dat to make the client boot up.
Now, it is redownloading the blockchain but at least it recognizes walletS.dat as expected.

I will try using a copy of the original walletS.dat into nu-2.0.0-Test4 if this is what you implied

I re-downloaded several times the blockchain on a machine running nu 2.0.0.
But each time I try to boot up Nu after replacing the empty walletS.dat file by the original walletS.dat file it crashes the client: at boot up (loading the wallets), it says that blkindex.dat is damaged and it won’t continue unless I delete the blockchain files.
In other words, it is as if loading the original walletS.dat file (made with nu 1.2.0) into nu 2.0.0 spoils the whole downloaded blockchain: the blockchain file will not load whether under nu 2.0.0 or nu 1.2.0 after loading walletS.dat
It is very weird and annoying since it means that I would have to manually import my private keys (luckily I have only 1 address of interest so it would not br that expensive time wise).
But still why walletS.dat loads fine under nu 1.2.0 and not under nu 2.0.0?
Any ideas @sigmike ?

what OS are you using?

edit: Oh I see you’re using the .exe on windows.

1 Like

You may have an invalid vote in your wallet. Try changing your vote with version 1.2 and then loading it in 2.0 again.

I cleared all my votes but still it won’t boot up.

FYI the relevant part of the debug log file

Nu version v2.0.0-beta (2015-08-07 14:14:37 +0200)
Default data directory C:\Users\xxx\AppData\Roaming\Nu
Loading addresses… LogDir=C:\Users\xxx\AppData\Roaming\Nu\database ErrorFile=C:\Users\xxx\AppData\Roaming\Nu\db.log
Loaded 6716 addresses
addresses 154ms
Loading block index…
PPCoin Network: genesis=0x000003cc2da5a0a289ad nBitsLimit=0x1e0fffff nBitsInitial=0x1e00ffff nStakeMinAge=604800 nCoinbaseMaturity=100 nCoinstakeMaturity=5000 nModifierInterval=14400
LoadBlockIndex(): hashBestChain=c7b4e4719c9130314fe7 height=483034 trust=708105189552
LoadBlockIndex(): synchronized checkpoint 000003cc2da5a0a289ad0a590c20a8b975219ddc1204efd169e947dd4cbad73f
Verifying last 2500 blocks at level 1
Upgrade Info: v0.4+ no txdb upgrade detected.
block index 11011ms
Loading portfolio…
Loading wallet for unit S…

******* exception encountered *******

EXCEPTION: NSt8ios_base7failureE
CDataStream::read() : end of data
C:\Program Files (x86)\Nu\nu.exe in Runaway exception

EnvShutdown exception: DbEnv::close: Invalid argument (22

Had to import manually the address that mattered from walletS.dat .

No idea why it could not be accepted by Nu2.0.0…

Another reason why you should always take backups on a regular basis.

1 Like

Have a look here (if you run Linux):

1 Like