Is it possible to run NuBits on a Raspberry Pi?


Is it possible to run a full NuBits node on my Raspberry Pi headless? If this is possible, does someone have instructions on how to do so?


yes, CoinGame makes the raspberry binaries, Can I install the 0.5.4 wallet on raspberry pi?

Do you know if this is an idiot proof guide lol? Kinda new to all this.

Yeah I got it working really well. It’s headless but that’s ok. As I remember theres a dependency or two that I found a bit tricky. The best thing to do is follow a guide for compiling the bitcoin wallet this should get you started.

If you post errors up here I’ll see if I can help and other folks are really helpful here too

1 Like

Headless is exactly what I am looking for. Do you by chance have a how to guide like the one found on the peercoin forums:

I don’t have a how to I’m afraid but it’d certainly be good to have one. I’m in new Zealand and it’s getting on a bit. If you can hold out until tomorrow I’ll see what I can write up for you. :slight_smile:

1 Like

Perfect, thanks so much.

ok here goes. I’m sure this guide isn’t absolutely perfect and you’ll probably end up installing things you don’t need but hopefully in the end it’ll get it up and running. I’m afraid I do somewhat fluff my way through this stuff, but i’ve always got it happening sooner or later.

I’m assuming you know your way round the terminal a bit?

1. You’ll need this file
2. save that on your pi somewhere. I just popped mine in a ‘nubits’ folder on my desktop.
3. This bit is taken from a guide to compile bitcoin on a pi:

– Update all existing software on the Pi (one line at a time)
sudo apt-get update

sudo apt-get upgrade

– Install the prerequisites required for compilation (one line at a time)
sudo apt-get install checkinstall subversion git git-core build-essential

sudo apt-get install libssl-dev libdb+±dev libminiupnpc-dev

sudo apt-get install libboost-dev libboost-system-dev libboost-filesystem-dev libboost-program-options-dev libboost-thread-dev

4. This bit is taken from this thread: Binaries for RaspberryPi or other ARM devices?

sudo ln -s /usr/lib/ /usr/lib/

5 At this point I’d probably go in to your nubits folder and run ./ARMnudv5.4 I think that’s the filename you downloaded in step 1?

You’re probably going to get some errors here. Post them up here (or copy them to google, this is pretty much how I got mine running). Still post anything up here and we can tidy this guide up in the end so there’s a really easy way for people to install.

I’ll be in and out the house today but I’ll keep an eye on this and help when i can :slight_smile:

Oh and anybody that knows more about this than me please feel free to correct me.


Nothing to correct but just to add an optional step which makes the handling of the client much easier:

  • copy the client to a location in the PATH and ensure permission:
    sudo cp ARMnudv5.4 /usr/bin/nud && sudo chmod a+x /usr/bin/nud
  • let it run in server mode, accepting commands via rpc:
    mkdir -p ~/.nu; echo "daemon=1" >> ~/.nu/nu.conf; echo "server=1" >> ~/.nu/nu.conf; echo "rpcuser=nupi" >> ~/.nu/nu.conf; echo "rpcpassword=xxx" >> ~/.nu/nu.conf;

Now you can start Nu by just running nud wherever you are and access a method by calling nud method. It furthermore keeps running when you log out of the ssh session.

1 Like

That’s really helpful thanks. I’m still running it from the folder. I’ll update my install with this

I followed this guide (with creon’s additions) on a Raspberry Pi 2 B. After all is done I run nud and I get this error:

bash: /usr/bin/nud: Permission denied

Working or not, this thing is really cool!

sudo chmod +x /usr/bin/nud

adding this in my post above, thanks!

1 Like

Thanks a lot! “Nu server starting”

it can take a while to download the blockchain. I had to keep restarting the pi as it would crash a bit. Just be patient with it though, it does get there

Yes it is progressing. I am getting about 250 blocks/min. The next thing I would like to do is have it run nud when the pi boots up/I log in. I tried adding a line for nud to /etc/rc.local, but I do not think the system can see the nu.conf file at that point in the boot process. I saw a message that I needed to add an rpcuser and rpcpassword, which I already have.

*please forgive any current and future linux noob lingo out of me

This is perhaps still useful for setting up a Raspberry pi from the very beginning

You can just cut and paste commands from Tea42’s scripts.