Can I install the 0.5.4 wallet on raspberry pi?

So I’m trying to install the wallet on the raspberry pi but having no luck at all. How do i run the binary? Can this be installed on the Pi and are there any instructions on how to get it going?


You have to use the ARM binary. See below.

1 Like

Thank you! I’ve been searching the forum for ages but couldn’t find the 0.5.4 one. :slight_smile:

Still having a bit of trouble getting this running. I’ve got all the dependencies etc installed then i navigate to the folder and run: ./ARMnudv5.4

The problem is it just hangs after that. At first I thought it was the blockchain downloading but I left it for a whole day and was still hanging. Also it uses 100% CPU on the Pi.

Any ideas?

Thanks for your help

Just to add to the above is it possible to get source to to compile a graphical wallet from or is the code still in the process of going open source?

Unfortunately, it still is.

thanks Willy. Don’t suppose you might have an idea why running the binary in the link above just hangs? I’m ok with using headless for now. It’s really just a minting machine.

No I don’t have a explanation for that, but maybe @CoinGame can help.

I don’t have any experience how long a RPi takes to synch with the block chain, but I can imagine that it takes a while to process ~ 250.000 blocks.

Thanks maybe that’s it and I just didn’t leave it going long enough. Just assumed 8 hours would do it

Actually, looks like it is downloading the blockchain. Just did a “getinfo” in another tab and looks like everything is working which is awesome!

So I think the only question I have left is: are there any docs on switching the wallets i.e. nubits - nushares etc? I know the rest of it should pretty much follow the Bitcoin API.


You can just use the documentation for the wallet I believe. and

exactly what I needed thanks. Looks like I can leave my old mac 0.5.2 wallet behind and get on to a 24/7 minting machine :slight_smile:

You need to start it with the daemon flag or else it will lock up the command line.

./nud - daemon

Nice one thanks I’ll do that after it’s DL’d the whole blockchain. It’s been on overnight and still going.

I did use a copy from the Windows wallet and copied that to my Rpi, which worked for me. That saved me the hassle of downloading it on my RPI which does take a while. Eventually it will get there if you are patient.

And you can also add a datafeed so you don’t have to look after it when you are busy or away for a while.

It’s nearly there now I think so might leave it ticking along. Will look at data feeds tho Cheers