Immediate mandatory upgrade: Nu client version 0.5.4

However, I still have 0.00NSR in stake and have not minted a block since 2/21

Does your client have the same block height as the block explorer?

ARM nud for 5.4 is here. As always… :warning: back up your wallets before using these builds :warning:

If you block height = current number of blocks, YES.
My estimated total blocks is different from the height.
My verrsion build date = 2/15 22:56:55 +0100

BTW, in my log file,

  1. Just noticed that nushares are considered as moneysupply… and not as shares.
    This is the same figure as given by
  2. Why does it not sum up to 1B?
  3. As for NuBits, moneysupply(B)=6286333.2604
    This is different from and superior to what is given by
  4. What does it mean? --> “ProcessBlock: ACCEPTED”
  1. It’s just expressing how much of that unit exists in the network. The label was never changed to express it as shares.
  2. NSR is created through the block rewards. It shows more than a billion because 40 NSR is created whenever someone mints a block. There’s also a 1 NSR transaction fee for sending NSR.
  3. Because the block explorer excludes NBT that were in the strategic reserve, since they will not be in circulation unless a drastic under supply occurs. CMC does this as well. This client does not do this and always shows the number of NBT that was created through custodial grants.
  1. I believe it means that you’ve accepted a block from one of your peers.
1 Like

Thank you @CoinGame. Anyone else having problems unlocking the ARM 0.5.4 wallet? It keeps saying that the passphrase is wrong, although the same walletS.dat unlocks fine on my PC (with the same passphrase).

That’s strange. I had someone else from the community test this build before releasing it and all core functionality was reported working. Positive you’re not fat fingering something? Tried wrapping in quotes?

Yes, I checked it several times, put the passphrase in quotes and even copy pasted the walletpassphrase command to the console of the debug window of the PC wallet. The PC unlocks, the Pi doesn’t.

Can someone maybe just give it a try and see if it works?

EDIT: lol nevermind, I forgot that I changed it on the Pi some time ago and it was forever unlocked for staking. Everything is fine. Thanks for the binary @CoinGame!


This topic is no longer a banner. It will no longer appear at the top of every page.

@JordanLee @Ben any word on the OS X build? I feel left out :frowning:

Also, is it worth discussing an automated build process? I’d be interested in helping out with that once the code is open source.

1 Like

OSX is coming up within the next day or so! Sorry for the delay.


Good morning!

I’m back from my trip and will be working on the OSX build today. Are any of you using the Nu daemon on OSX, or primarily the QT (GUI client)? I’ve been fighting a toolchain issue with 10.9.x and up systems that makes compiling a static version of nud difficult (same for Peerunity, so it’s related to Boost and OpenSSL with the changes that Apple made to their GCC compiler, not with our software). If it’s not needed by the vast majority of users, I’ll skip it for this version and just get the GUI client out ASAP.

Let me know. If you need it, I have a couple of possible options that we could try, individually.

Thanks, and I really am sorry about the delay – I’m in the same boat as the rest of you and am chomping at the bit to get back to minting on my Mac.

Welcome back Ben.

I’m using the Qt Nu version v0.5.3, and i’m looking forward to the 5.4 upgrade for the Mac


1 Like

Still working on this. I’ve been cursing Apple’s name for changing their compiler and messing up a good thing.

Continued apologies for the delay. I need to build a new 10.8.6 VM.


Successfully built Nu 0.5.4 for OSX! I need to run a few tests to make sure it works correctly on machines without pre-existing dependencies and then I’ll sign the binaries and get them published.

Thank you all for your patience while I worked through my environment issues.


@Ben kool, thanks. Quick question, when updating to the 5.4 do all my Nushare need to finish staking first?

Quick answer: No.

@willy thanks.