I cant download the blockchain, getting 3kb/s and getting slower

The speeds even with 8 peers has continued to be 5kb/s for days now and has dropped to 3kb/s on average. The first 30% of it actually moved enough to be patient with it where i could see the days left drop in realtime but ever since it reached 360 days left its slowed to a crawl, i left it on all night and it only dropped by 3 days, at this rate it will take me several months to download the blockchain. Is there no other way to download this?

how many node are you connect ?

1 Like


That’s really strange. When I sync from scratch it takes at most a couple days. Maybe you are connected to slow nodes? Is this your experience with downloading other blockchains or is it unique to Nu? We can try to help improve the current performance but until 2.1 is released there aren’t many better options. 2.1 will support bootstrap files which you can download through bittorrent or direct from a server.

Ive tried restarting it, closing particular node connections so it restarts them, setting the -timeout flag to 10 minutes to it does this automatically, nothing works, all the nodes are horrendously slow, i can get 300kb/s downloading through utube or whereever so its not my internet and i got nothing else running but nubits.

I dont get why someone cant upload there blk001.dat file so i can use that instead of having to download from these nodes running off of 14.4k modems


Maybe try deleting your addr.dat file in the data dir so your first connections are from the seed nodes, and possibly get a fresh list of new peers instead of the ones you currently have in your list.

Ive deleted addr.dat and added the supernodes, looking at my active connections its not connecting to any of the supernodes. Still 3kb/s and no blocks downloading.

Ive tried the -connect flag to force it to connect to the supernodes, it looks like they are rejecting my connections, maybe they are running behind cloudflare or some sort of firewall.

For the record im stuck at 347 days left, it hasnt budged all night, blocks were decrementing quickly yesterday and now are going down at about 3 per minute (out of 344787, which is half of what it said the total amount of blocks was yesterday).

Can someone upload their blk0001.dat and blkindex.dat files?

What version of the client are you running?


blkindex.dat is currently being uploaded. This will take some time. I will update this post.

sha256sum blk0001.7z
32e4306328a9733963a3c5cbe21e70e8d08ae3932afa189d4ab2ffcc1e61a302   blk0001.7z
sha256sum blk0001.dat
8178f18f736e6d89de3929a69321d3a940a1df506ac922c86936085de70834b4   blk0001.dat
sha256sum blkindex.7z
83384c829c5a31855e9701c8bab7b0c7baf18f3b696205c573314310b6112b79  blkindex.7z
sha256sum blkindex.dat
7aedd4101d332d3235a3124aa19aefc76383553bf0b874544a28bcabe69a166d  blkindex.dat
1 Like

Thanks, im running 2.0.3, this is all sorts of painful. It just changed its total block count to 690618, from 344787, it does this everytime i run the client, so now instead of being 50% there im only 25%.

Downloading your blockfiles now…

Well it downloaded ok, extracted to the data directory, it returns this error:

EXCEPTION: 11DbException
Db::open: Invalid argument
nu in Runaway exception

This is a blockchain, it should be identical for everyone, why would this return an error?

Either the files are corrupted or it’s something different.

The dat files are from my RaspberryPi running Raspbian.
I’ve compiled nud with BerkeleyDB4.8.
Do you use an official wallet software or did you compile it yourself?
I suppose you compiled your own version.
BerkeleyDB4.8 files might not be compatible with your version of the Nu wallet software.

Can you test the files with an official Nu wallet version from the download section on any machine - just to make sure they work?

Yeah once this is done i can jump onto windows and try the windows client. It looks like its going to be at least 7 more days at this point

We can try to help improve the current performance but until 2.1 is released there aren’t many better options.

Doesnt look like 2.1 is going to be released:

Re: [ANN] B&C Exchange - A decentralized exchange paying BTC dividends

October 20, 2015, 03:21:55 AM

sigmike has spent the last month on Nu version 2.1, which is also now code complete and partially tested.

2.1 has been code complete since october and now its janurary, it looks like development is dead.

Here is a list of the changes in 2.1. They are extensive changes. It is not a simple feature update like previous releases. The blocker right now is performance related. Once we identify the source of the performance issues and fix them it should be ready for release.