NuPool 2 now active on Bittrex and Poloniex

I can confirm that I’ve received the payout almost 2 hours ago.
Thank you for your continuous outstanding support - I’m aware that today is Sunday :wink:

getting these errors, is this pool still working, i know it has been a while. Wanted to try it but i guess it isnt working
(the support ticket system isnt working? i tried asking there first)

Edit 3: It has been almost 5 hours with no issues. I am therefore sure that the problem is resolved. If anyone has similar issues then it might be worth installing nscd as I suggested earlier.

Hi, I’ve been testing using NuPool Poloniex BTC/NBT and LiquidBits CCEDK USD/NBT at the same time. I get many errors like (removing duplicate errors):

2015/06/24-17:51:46 ERROR: submit: socket error (-2)
2015/06/24-17:51:47 ERROR: unable to retrieve server price: socket error (-2)
2015/06/24-17:51:47 WARNING: need to resynchronize trading bot for btc on poloniex because the deviation reached 30.07
2015/06/24-17:51:54 ERROR: submit: socket error (101)
2015/06/24-17:52:42 ERROR: unable to synchronize time with server for btc on poloniex: time difference to small
2015/06/24-17:52:42 INFO: waiting 2.29 seconds to synchronize with other trading bots for btc on poloniex
2015/06/24-17:52:51 ERROR: unable to receive balance for nbt on poloniex: Nonce must be greater than 1435164769635. You provided 1435164766550.
2015/06/24-17:52:51 INFO: adjusting nonce of poloniex to 104
2015/06/24-17:53:27 INFO: adjusting nonce of poloniex to 205
2015/06/24-17:56:00 ERROR: unable to receive balance for nbt on poloniex: exception caught: <urlopen error [Errno -2] Name or service not known>
2015/06/24-17:58:02 ERROR: unable to receive statistics for user XXX: socket error (-2)

The errors go away (except for “Nonce must be greater than” errors on Poloniex) if I stop both clients and then start one of them. But the errors start again when I start the other client. I can only run one at a time without running into errors.

They appear to be conflicting in some way.

Edit: I’m using Linux (SolydXK following debian jessie), python 2.7.9. If more details are needed, ask.

Edit 2: It seems the Linux problem was due to a DNS resolving issue. I installed nscd and the errors do not appear now. It could be that there is a workaround in python. I’m not sure exactly what the cause of the issue was but if anyone has problems on Linux try installing nscd with sudo apt-get install nscd if using a debian based system.

I did however get one more nonce error at the start. Maybe it wont reappear now.

Can/should we use Plunge with this - or is it better to just use the python shell?
I’m on a windows machine.

As you prefer. The python shell should be a little more recent but plunge should work fine if you like GUIs.

Are payments automatic? They seem so - bu I did not get anything today from NuPool and I had a balance greater than 1.

Good morning @nmei.

Apologies, the missed payment is my fault. I was called away at short notice yesterday and was unable to transfer sufficient funds to the pool hot wallet.
The second period ended a couple of days ago but I havn;t had the time free to submit a new proposal. I am going to make some time to produce that today. The compensation will remain the same at 9% per month but the target will come down to 30k from the current 50k. We still have funds enough to cover the vast proportion of the next operation (which is why I wasn’t overly worried about the overrun of the last one, the compensation being the same). I’ll do the exact maths and post a new topic when it’s ready.
Once it’s up I’ll restart the server with the new settings and kick it off again. I’ll do a manual payment at the same time.

1 Like

Just to add: We’re trying to get some competition into NuPool again, as most of the time, the rates were at 0.3% on all pairs.
Also, it couldn’t hurt to reduce our influence in the tllp business to leave room for NuPond and LiquidBits.

Thanks! I understand. I’ve already been pushing some funds to the other pools.

I’m not clear about lowering the target though and the impact on % yield. I understand that will make competition. So when I set my % targets that I am willing to accept - is that what I will be given granted that no one is lower? Or will it give me more based on market?

You get the max % unless the target is full, then you’re in competition. At that point, you receive a smaller percentage on a portion of your liquidity, corresponding to how much competition there is. Your set % is the minimum % you are willing to receive; if the competition pushes your reward below that (so you are no longer being compensated) the bot will delete the orders so you are no longer at risk.

1 Like

Thanks. I’m sure that was explained on the site. I just didn’t understand it until right now.

1 Like

Since you cannot know what the competition will choose, it is always in your best interest to enter the % as the actual minimum percentage you are willing to accept for your liquidity. There isn’t really a good way to game that parameter by design.

1 Like

You are no longer at risk of volatility (tier 1 = 0).
The risk of exchange default remains as the funds stay at the exchange (all funds in tier 2) :wink:
Would be nice to have a way to automatically shift the funds from the exchange to tier 3 (attempt to make that function available).
But for security reasons it would be necessary to tie an API key to an NBT address that can’t be changed afterwards (to make sure the API key in the wrong hands couldn’t lead to stolen NBT).

1 Like

I have a question: I’m testing with a small amount (100 NBT) on Poloniex only. I followed the instructions on and set pool.conf with the two keys as required, a NuBIt address, and exchange=poloniex. I’m running the client from the CLI on Linux. My NBT funds are acknowledged by the client, bid/ask orders in the amount of 0.5 NBT are routinely placed, but in the 2 days it’s been running, the logs show I’ve never seen a balance other than zero and I’ve received no NBT. I’ve tried a variety of bid/ask interest rates between 0.1 and 0.3 without any effect. Am I doing something wrong or is the pool on Poloniex oversubscribed?

According to the current status, the poloniex ALP looks like this:

The ask side is close to the maximum and whenever it is above the maximum, the liquidity providers will see a degradation of the average compensation.
But you are providing NBT on the bid side and there’s some space left until the maximum is reached.

If you don’t mind trying a different bot, you can have a look here: Universal ALP bot collection - forked (and hopefully improved) @Nagalim edition :)
The experimental branch is the most recent:

I have my ALPs bot running based on that code and my poloniex ALP bot tuns fine.

Hi Guys,

rather new to this stuff I set up the NuPool software on both Poloniex and Bittrex and on a Win7 machine and it worked well for almost 2 Days. I editet the pool.conf accordingly and used the python run_client because the batch file in the windows folder didn’t work. Having collected over 0.4 NBT over night it showed only 0.01 NBT when I returned in the morning. Studying the log everything seems to be fine except a 2 minute period showing a lot of error messages such as ERROR: submit: server response invalid
ERROR: unable to retrieve server price: server response invalid
ERROR: exception caught in main loop: global name ‘logger’ is not defined
ERROR: submit: user not found
After that behaviour, all balances were reset and it started working as usual again.
I do now have an 60 NBT order on Bittrex which can not be cancelled and is considered as invalid.
Did I make something wrong or was there only a disconnect over night?
Is there a chance to get that order back when I contact bittrex support?

Any help would be highly appreciated.



you can login bittrex and cancle the order manually.
also restarting the bot cancels all existing orders.

No way to cancel manually or restart, Tried this more than once. Order is invalid I am told. Contacting Bittrex support now.

Let’s see what happens

Yah, that sounds like a bittrex issue. Sometimes the bot does weird things, but a restart should clear all orders and right itself. An invalid order is something bittrex support with have to fix.

I saw the same issue a few weeks ago. The support removed the stuck order within 48 hours…