Nu blockchain stuck for 1day now

It’s been about 24h now since i cant dl any block.
Machine: windows 8
I am using it for providing a voting data feed for Nu with no nushares on it.

Anyone has any idea?
Also, how can safely copy and transfer a correct updated blockchain if that becomeds necessary?

Do you see any worthwhile (error) messages in your NU debug.log ?
Do you use a firewall/antivirus (which may interfere)? e.g. firewall software updated and did something "bad"
Which is the last block you could download successfully ?

1 Like

In addition to @erkan:

  • have you tried restarting the Nu wallet?
  • what version is it - 2.0.3 or 2.1.1?
  • do you have nodes in nu.conf?
1 Like

I dont have my machine with me right now but:

  • I tried to restart
  • It’s 2.0.3
  • I have nodes

Would it be possible that I am on a fork?

Hard to say that without being able to ionvestigate the hash of the blocks.
I’d say it’s more likely to find another explanation that’s related to your network connection or things like that (a system update that broke things, changed the firewall settings, things like that).

You took the nodes for nu.conf from here?

Will check that asap

my list:

Last received block: 887752
generated 2 days ago (Mon May 23 20:33:32 2016)

Seems like I got 3 type of errors:

  1. quite a few of these:
    ******* exception encountered *******
    ERROR: bool CTransaction::ReadFromDisk(CDiskTxPos, FILE**)() : deserialize or I/O error
    ERROR: CheckProofOfStake() : INFO: read txPrev failed
    WARNING: ProcessBlock(): check proof-of-stake failed for block

  2. many of these:
    ProcessBlock: ORPHAN BLOCK

  3. quite a few of these
    ERROR: CheckProofOfStake() : INFO: check kernel failed on coinstake d84ecd91cc5b42d0edd9de203769e4293ad792942f6c2a08262fbd22db515274, hashProof=0000000000000000000000000000000000000000000000000000000000000000
    WARNING: ProcessBlock(): check proof-of-stake failed for block 21a3b05067951ed0bf00417d056f1588bb7ba73d0ddfabe97263c662b1ad94b4

I am not running a firewall but tor, and bcex and peercoin are running fine (both for signing or providing feed purpose) –

looks like you got some file system corruption, have your computer rebooted recently? you might have to redownload blockchain by the looks of things

Not that I remember

Anyway that I can transfer and copy safely the blockchain and other data from one other updated computer?

as long as versions are the same

That sounds good – do you know exactly which file should do the trick?

make backup of old data directory, then just copy the whole roaming data folder of nu from working machine, and replace wallet*.dat with the ones that you’ve backed up. that should work

1 Like

Make a disk scanning, perhaps it has bad sectors! Is it SSD or HDD?

Use HDtune and perform an error scan (not a quick one).
It is a slow procedure but if you see red sectors then you need to replace the HDD :slight_smile:

1 Like

It failed to load the blkindex.dat

both machines run 2.0.3 on windows? and loading working blkindex.dat does not work???

Absolutely –

Did you shut down the Nu wallet on the machine from which you copied, before you started copying thd application data folder?

transferred everything except and the keys