Datafeed: unsupported protocol error

Trying to make a working datafeed, but keep on getting an error message in the client: Data feed failed: unsupported protocol.

My datafeed lives here and I have validated it twice to ensure there are no typos, but maybe I’m still missing something:

Any ideas?

What is the URL you give to the client?


This URL returns an HTML page displaying the formatted data, not the raw data. You must use the URL provided by the “Raw” button: does not work either here. --> unsupported protocol.

Got [Warning: data feed was changed but the initial fetch failed: Data feed failed: Unsupported protocol] on the command line.

EDIT: added information.

What system are you using?

Hmmm strange. I’m looking into this now.

Cybnate’s feed works fine for me when I used the correct link. Anyone else besides @cryptog having trouble?

I am testing on win 7.
Perhaps my issue is caused by the fact that the blockchain has not been fully downloaded on my client? Downloading it right now.

That shouldn’t cause a problem. Can you verify that you’re using the raw link?

yes. confirmed.

Okay. I’m able to see this on Windows 7 as well. I’ll work with mike to troubleshoot.

I got the same error on Linux when I tried the github link. Then I downloaded the json and put it on my localhost http server. From there the feed could be imported without error. Maybe it has something to do with github? And yes, I used the raw.githubusercontent version.

That’s odd. I just used the raw link on Ubuntu a few minutes ago and it worked for me. I’m currently running some self hosted tests as well.

1 Like

I present you with the ARM nud for 5.3. Considering ARM binary is still not an official build, and 5.3 is still in beta, please consider this build a super beta. :warning: Use at your own risk. :warning:

This still needs all the Peershares dependencies installed first.

You will have to install libcurl before using it. Running the command below should get you moving.

sudo apt-get install libcurl4-openssl-dev

I did not have a problem using @Cybnate raw github URL on my RaPi. Let me know if there’s any problems.


I posted this in the wrong topic… derp. I’ll just link to this post on the beta release topic.

Is the client checking the Content-Type of the returned document? If so, a service such as may be helpful. Github only returns text/plain from the domain.

No, it only checks the content.

The problem certainly comes from the way we build the curl library that makes https not work on some platforms. We’re working on it.