Blockchain still not downloading


#1

In view of the high bitcoin price, I thought I’d buy NuBits - but then I remembered my blockchain was not downloading (under version 4.0.0)

I have today downloaded version 5.0.1, but my wallet will still not move past 1164045 blocks of history (last block generated 154 days ago)

Any suggestions on how I can solve this? Thanks


#2

i think you should download the blockchain from scratch under v5.0.1.


#3

What does the log say about the last downloaded block? Look for the last occurrence of “received block” in your debug.log. Is there any error after that? You can also look for the word “ERROR” near the end of the log.


#4

Where do I find the log?

I went to Help > Debug Window and looked through the list of commands, but could not find anything that seemed to be a log

Thanks


#5

It depends on your system. Look at this documentation:
https://docs.nubits.com/creating-conf-file/#find-the-nu-data-directory

The log is in debug.log in that data directory.


#6

It’s been a while, but I have looked tonight and found the debug.log file. The last instance of “received block” (at the end of the debug.log file) is copy-pasted below. It also contains the word ERROR. Can sigmike or others see why the blockchain is not downloading from this information? My client is an old one v5.0.1-beta. Thank you.

+++

Received 89 bytes from data feed https://raw.githubusercontent.com/Cybnate/NuNet-datafeed/master/Cybnate-datafeed.txt:
IFEa9YYsZW08QgB2TbreYE3kJyUx/iOGP+aGe5fD+HpmXjB7hN+AujXGAADctp+hSAPeRpgfzmvKHjxI+blFpu4=

Vote updated from data feed
sending getdata: block bd5862d8e5253a12dd25
received block bd5862d8e5253a12dd25f0b3645be558c3567341446d3251ed117606987300c8
ERROR: CheckProofOfStake() : INFO: read txPrev failed
WARNING: ProcessBlock(): check proof-of-stake failed for block bd5862d8e5253a12dd25f0b3645be558c3567341446d3251ed117606987300c8
DBFlush(false)
addr.dat refcount=0
sending getdata: block 22a52d06d9caee38c31b
ThreadSocketHandler exiting
addr.dat checkpoint
ThreadUpdateFromDataFeed exited
addr.dat closed
blkindex.dat refcount=1
walletB.dat refcount=0
walletB.dat checkpoint
walletB.dat detach
walletB.dat closed
walletE.dat refcount=0
walletE.dat checkpoint
walletE.dat detach
walletE.dat closed
walletS.dat refcount=0
UPNP_DeletePortMapping() returned : 0
walletS.dat checkpoint
ThreadMapPort exiting
walletS.dat detach
walletS.dat closed
walletX.dat refcount=0
walletX.dat checkpoint
walletX.dat detach
walletX.dat closed
walletY.dat refcount=0
walletY.dat checkpoint
walletY.dat detach
walletY.dat closed
StopNode()
ThreadOpenConnections exiting
ThreadMessageHandler exiting
ThreadStakeMinter still running
DBFlush(true)
addr.dat refcount=0
addr.dat checkpoint
addr.dat closed
blkindex.dat refcount=0
blkindex.dat checkpoint
blkindex.dat closed
Nu exiting


#7

Does your problem remain with v5.3.0?


#8

Hi, Jooize

I have not tried (yet). Is there is specific reason why you think it should work with a later version? It ought to be working regardless of version - did v5.3.0 solve a problem that might relate to my issue?

I want to try and get the blockchain downloading with my current client, before upgrading clients, as I am concerned changing clients might complicate matters.

Perhaps @sigmike can comment on the debug.log, first?


#9

I’m not sure. v5.1.0 would be the one in that case. You can copy your entire wallet configuration directory and try the latest wallet with only one of them to prevent irreversibility.

Block in question: https://explorer.nubits.com/block/1414014

Our blockchain up until September 17th is available for download via BitTorrent. I’d try using it.


#10

What is the purpose of using the blockchain download from Torrent - is it simply to save me the time of downloading the blockchain via the client - or is it a means of bypassing the obstace I am presently experiencing?

Thanks.


#11

Usually to save time, but since you’re having trouble with a block, I thought it’d be worth trying until @sigmike can give a better answer. :slight_smile:


#12

I uninstalled the old version, and installed 5.3.0 - the blockchain did not need to download afresh, since the previous blkindex.dat file was retained on my C drive

However, the blockchain is still stuck at 1164045, last block received 320 days ago

How do I download from the very beginning - do I delete blkindex.dat? What about blk0001.dat?

Thanks.


#13

blk0001.dat is the raw blockchain. NuBits Wallet processes blk0001.dat to place shortcut references in blkindex.dat which improves performance of the wallet.

Try rebuilding the index. Close NuBits Wallet, then rename blkindex.dat to blkindex.dat.disable, and start it again. Let blk0001.dat be.


#14

Thanks, Jooize
I have done as suggested, and the blockchain is now downloading. It is quite slow, but steady. Presently 66% done, 389 days to go.
I have not yet passed the previous “blockage”, so will wait and see what transpires in the next day or two.


#15

How has it gone, @matthewd?


#16

Hi, Jooize
Thanks for your follow-up message
I am pleased to report that, this afternoon, the wallet/blockchain completed its download fully.
In fact, I noticed several days ago it passed the “blockage” point, but did not report this - as I did not want to tempt fate!
Many thanks,
Matt