Binaries for RaspberryPi or other ARM devices?

check out for the full list of commands and info


@CoinGame always is a little late.
…so he can’t be a wizard!

He’s a wizard, but living in the “Old Country” introduces “wizard lag”

1 Like

I’d rather be a necromancer… or a paladin. We still talking about Nu stuff or dungeons and dragons?

My assumption that you’re no wizard was referring to a dialogue between Frodo and Gandalf in the movie “The Lord of the Rings”:

1 Like

I never saw the movie… Now i’m outed as a RaPi noob and a LotR noob.

I recommend the extended editions if you ever plan to watch the movies. The cinema cuts suck in my opinion.
But hey, you’re the RaPi noob who compiled a working Nu client!

…could’ve done the same if I had access to the source code :stuck_out_tongue:

NuBox can live on existing Peerbox installation.
However, Nu is still closed so I can not compile binaries. I know someone who has access to source code can do it and give me the binaries but I’m not ready to play that.

I see no point to rush with this, allow me to complete stable Peerbox and then this can be simple extension.

If you have any questions please ask, I do not come to this forum often but P.M. me.

I’ve started to play with the daemon for RaPi and encountered problems that I could reproduce in the debug windows of the Linux QT application.


doesn’t work like it should. There’s always “Error: type mismatch” reported when trying to set votes. I searched but found no help.

Even if you copy the example from

[quote]help setvote

setvote '<'vote>
is the complete vote in JSON. Example:

to a

it produces an error message…

Error: type mismatch

Is that what you see?

That’s what i’m seeing.

The daemon creates - to be precisely - the message lowercase only:

error: type mismatch

In your command posted above you close the set of ‘addresses’ with ‘]’ but there is no opening ‘[’ before the first ‘address’. That could cause an error if you’re using that exact command.

Well spotted. I need a better editor than gedit to keep track of the brackets…
Anyway, I tried to copy the output from “help setvote”

help setvote
is the complete vote in JSON. Example:

as well as other variations. No success.

The most simple "setvote should be

setvote {“custodians”:[],“parkrates”:[],“motionhash”:""}

but that doesn’t work as well.
Whereas ‘setvote’ expects a complete set of votes in JSON, there’s


to solely set a motionvote. This works.

we’re looking into it.

Try wrapping the getvote command in single quotes

setvote '{"custodians":[{"address":"bPJcVprJmqQgN6fc2C3gFXdiA1e5jByFhd","amount":100},{"address":"bG3vRFNo7GxV2JJjo1YRXTkr4B2yoRWWNy","amount":5}]}'
1 Like

The addresses are reported to be invalid (new error message; yeah!), but I bet that was on purpose. Wrapping around the command in single quotes did the trick.
I took a valid NBT address and guess what… :wink:
You solved it!

The compete set of votes works as well when being wrapped.

Did I give you a hint by accident when writing this? :smiley:

@sigmike solved it :wink: I am just the messenger

Aahhh that’s wise. Then it is you who gets shot if the message is bad :wink:
Bravo @sigmike!