Alcurex withdrawals/deposits (working as of Dec 8)


#1

How about the wallet?


#2

I recall seeing the title being about Alcurex. Withdrawals remain unresolved. I’m in contact with an admin, but response times are long.

@louis: I edited the title, please say if you were asking about something else.


#3

@jooize thank you very much.my english is poor,I do not know alcurex well ,and very worried about my nushare in view of the btc-e.


#4

We have the release ready!

  1. Upgrade to Nu v5.2.0 at https://discuss.nubits.com/t/nu-5-2-0-release/5409
  2. Clear your nu.conf and use the four recommended options.
  3. Ensure connectivity by adding nodes in nu.conf from https://discuss.nubits.com/t/5387
  4. Start the wallet.
  5. Consider using the mergeoutputs RPC.

We are more than willing to pay you compensation for the efforts spent on us.
If you run into any issues, please do not hesitate to contact us at info@nubits.com or sigmike@lepton.fr


#5

Alcurex has enabled deposits, which I can confirm functional. However, I could not withdraw NSR.

NuShare buybacks will be performed in combination at Alcurex and our Manual Exchange for the lowest available price.


#6

That is great news. Are they running the new client? Still issues with withdrawals or are they still testing?
The withdrawal issue should have been solved with 5.2 client with correct config.


#7

They will need some more time to solve withdrawals. Good news are they’re responsive.


#8

are the withdrawals enabled?


#9

Withdrawals of NSR at Alcurex are still not functional.


#10

ok tks.


#11

Hi Alcurex,

We’ve spoken via the chat as nu_jooize. Important part is at the end of this message, the rest is only a recap for completeness.

I figured tracking the issues is likely easier via the tool made for it. Please say if you feel bothered, as that’s the last thing we want. I’m obligated to make sure I do everything I can to keep our network functioning. As always, we can compensate you for the trouble.

Problem is that withdrawing NSR usually fails. One million can succeed, two million, but three failed. Then one million failed after that.

Instructions for our latest wallet were, just have them available, as follows:

  1. Upgrade to Nu v5.2.0 at https://discuss.nubits.com/t/5409
  2. Clear your nu.conf and use the four recommended options.
  3. Ensure connectivity by adding nodes in nu.conf from https://discuss.nubits.com/t/5387
  4. Start the wallet.
  5. Consider using the mergeoutputs RPC.

You followed those steps, but got the following error:

SendMoneyMultiTx() : Error: Transaction creation failed

To resolve the problem, we first need to see the lines in the log before that error message.

Thank you,

Esko (jooize)
Manager, Liquidity Operations, NuBits
Sweden

Hi NuBits,

Thank you.
I will follow your instructions and will let you know.


#12

are bitcoins withdrawals working on alcurex?


#13

Yes.

NSR withdrawals usually work in amounts less than 1 million.


#14

ok tks for the info.


#15

Hello. Do you think you have problems? Recently did a translation on alcurex ID 811195f1976146e7dc84becdfabf7e123f962268a2f69434094af6d5bd2fcffb two days passed and the money never came. http://prntscr.com/gwnxng


#16

Thanks! Found the logs?

We’re concerned for the 200M NSR we have.

Hi NuBits,

I have install NSR to the new server following your instructions.
I test sending 5000000 NSR

Errors on log file are:
ERROR: CreateTransaction: signature failed
ERROR: CreateMultiTransaction on transaction 1/1: CreateTransaction failed
SendMoneyMultiTx() : Error: Transaction creation failed

Do you build from source or use provided binaries? We’re creating a more verbose version that should help debugging. Which OS does Alcurex run for wallets?

Please set debug=1 in nu.conf, then install version v5.3.0 and try again.

https://bitbucket.org/JordanLeePeershares/nubit/downloads/nu-5.3.0-linux-gitian.zip
https://bitbucket.org/JordanLeePeershares/nubit/downloads/nu-5.3.0-win-gitian.zip

What is the exact command you run, and is the wallet encrypted? I had a problem when trying to send with an insufficient walletpassphrase timeout.

Thanks, and good luck!

Esko (jooize)
Manager, Liquidity Operations, NuBits
Sweden

nu.conf should contain the following:

debug=1
multitx=1
stakegen=0
splitshareoutputs=0
avatar=0
addnode=212.129.19.120
addnode=188.166.70.219
addnode=78.47.85.196
addnode=159.226.88.23


#17

Hi NuBits,

Hello.
Our conf is similar.
But we had wallet version 5.2, so lets try if new one solving issue.

passphrase time limit is now 120 sec, but I can try longer…like 360.

Will let you know after test…

Hi NuBits,

I have test sending.

with longer passphrase time, it works.
Seems that wallet sending transaction like over 2 minutes.
This is not problem, but…
after 30 seconds, wallet response RPC error data… even it will continue trying to send transaction and finally got it or fail.

Because of that invalid error status response, it is very hard to see which one transactions are really sent and which one failed.
Im already mess with our past NSR transactions, because some of have error status even it has been sent.

What you propose how to continue?

Hi Alcurex,

Thanks for the immensely useful information! I understand the problem. We’ll discuss and get back to you.

Esko

Can you send us the debug.log, or the relevant messages above the error in debug.log?

We may have a simple fix!

  • Set a very long walletpassphrase timeout for this operation, a few hours just to make sure.
  • Run ‘mergeoutputs’ RPC without arguments. It will take time.
  • Then remove ‘multitx’ from nu.conf, which will disable sending using multiple transactions.
  • Set walletpassphrase timeout to regular length, 1–10 minutes.

All transactions should succeed after doing that, until many deposits with large number of outputs. It would be best to run ‘mergeoutputs’ regularly, or on deposits, but you may get by with doing it manually occasionally.

If the timeout expires before the last transaction is sent it would fail with a signature failure because it’s unable to load the encrypted private key. Running ‘mergeouputs’ would make everything easier. The ‘mergeoutput’ command itself would take quite some time, but after that sending transactions will be much faster.

I’m sorry if it’s caused a mess with customer balances. We want to make that right, so if you make sure every customer gets their shares, we should be able to cover any differences for you.

Tell me how it goes,

Esko (jooize)
Manager, Liquidity Operations, NuBits
Sweden


#18

Good news!

Alcurex withdrawals are now functional. Up to 5,000,000 NSR per withdrawal, and you can repeat rapidly. 25,000,000 NSR was requested to be withdrawn within one minute and all successfully reached destination.


Where to buy
#19

Great news!


#20

Hi to all! New trouble with Alcurex NSR wallet. Can’t deposit NSR…