[Passed] LiquidBits term 7 grant (updated) - Automatic Liquidity Pool (ALP)

I haven’t checked the API, but I recognized the change on the website as well.

If it does require a change, don’t forget to change the number of characters in that one line in utils.py and the line after it.

I asked CCEDK to remove the ‘-’ between the US and NBT as someone else asked coinmarketcap.com (CMC) to use the USNBT denomination instead. I hoped that this change would make CMC recognise CCEDK and the BKS market again. This doesn’t appear to be the case though. I’m intending to contact CMC about this unless someone PMs or asks me in this thread not to or is already taking care of this.

Re API; I asked CCEDK to not touch the API or inform us if required. The change can be made reasonably quickly if needed, but I haven’t encountered any problems yet even after a restart of Pybot where that was the case with the previous change. Please let me know if you encounter problems and I will test and make the change asap.


my client as been stuck in the beginning with no output. When pressing ctrl-c it says the config file couldn;t be read, an error that happened before and was found associated with reading ccedk time-out.
Any clue?

Looks like we need to change the API with CCEDK again from US-NBT to USNBT
Will publish a new release and restart the server after next payout.

Edit: new 1.6 release published: https://github.com/Cybnate/nu-pool/releases

This version still doesn’t work. but I figured it out

in exchange.py this

if unit[‘pair_name’][:7] == ‘usnbt/’:

should be

if unit[‘pair_name’][:6] == ‘usnbt/’:

“6” is the number of characters in 'usnbt/'. It was 7 but should be 6 now. I don’t know how everyone else’ client could have worked.

The code really should have better debugging info to show trace of execution.

Could have helped me there. Oh it did register in my mind and helped.

1 Like

Thanks, because of that problem it also took a bit longer to get the server restarted.
All running again by now.

And published release 1.6.1 with the error corrected: https://github.com/Cybnate/nu-pool/releases

As long as you don’t restart it, it continues to work. With the server restart everyone needs to update.

1 Like

A while ago the NuRPC and the server.py became detached for an yet unknown reason. Therefore the by LiquidBits provided liquidity is no longer (correctly) broadcast on the network but still available on the exchanges. The only way to fix the broadcast is to restart the server.py and Nu. I will do that after the next payout around 7.40am UTC to minimize the impact on the payouts.

The restart didn’t work, the Nu daemon was still not able to broadcast.
Updating the blockchain to Nud v2.11 now. This may take a while.

The broadcasting is still not working. Anyone any idea what might be causing this:

2016/04/10-12:05:41 ERROR: NuRPC: unable to send liquidity: Failed to process info.

Does nud respond to rpc commands? Can you getblockcount and sfuff?

Problem has solved itself after nud v211 upgrade. It did accept the unlock wallet account RPC command yesterday, haven’t tried anything else after that. Will keep an eye on it.

There are still issues with the LiquidBits server. I’m unable to place orders on Poloniex and Bittrex although the PyBots believe all is fine. Orders on CCEDK are fine, but the automatic payout didn’t come through. Apparently there are some Cloudflare issues affecting this and other operations. I’m sitting it out until it is clear what is going on before reverting back to a backup tomorrow if it doesn’t resolve itself.

nbt/usd on ccedk: i have been getting 0.00% rate for 2-3 days and have stopped my bot. there is 2nbt on the buy side since maybe yesterday.

Sorry for that. I have been seeing a number of different issues which seems to be related to Cloudflare affecting Poloniex. And the bots are still not working properly, which is most likely related to the newly introduced nud v2.11. Nud v2.11 came into play because of liquidity broadcasting issues.

Will restore a backup with nud 2.03 and see if we can get things working properly again.
Will have an outage for potentially 2-3 hour or longer depending on success of restore.

1 Like

Restore done. Bittrex and Poloniex bots are back online, CCEDK bots working.
However, still facing the liquidity issue (Failed to process info) which also means no payouts for CCEDK bots until solved. Tried the repairwallets and checkwallets and all returning true. Just reverted back to an old chain which is now synchronising. Still facing the error…

This is a new issue which I haven’t encountered before. Possibly something with RPC connection, but nothing has changed. Running out of time here, will look into it tomorrow again.


The server crashed with a new type of error in threading.py, the Python code. Will go back further with the backup and not run apt-get, as that is the only newly introduced code, possibly some updates with python. Will attend to this in next 12h.

I’m unable to even start server.py at the moment as it just stalls. Situation is serious indeed.
Poloniex and Bittrex wall are therefore not supported by LiquidBits.

1 Like

Have gone back to a 2 weeks old backup. Replaced the walletB with an even older backup as it showed a different balance after being syncronised despite the keys were the same. Can’t explain this. Balances of both wallets are now the same. Restarted the server and the same error:

NuRPC: unable to send liquidity: failed to process info.

still continues.

The server now runs without recent Python updates, but is still not broadcasting liquidity properly. Orders have been placed on all exchanges and rewards are calculated, but there is a high chance that it fails again in the next 12 hours or that there won’t be a payout because of the liquidity error. This based on experience earlier this week.

It appears that there is something strange with RPC connection, but is unclear why that is suddenly occurring as nothing has changed in the wallet or the application code.

Any suggestions on what might be going on are more than welcome as my options are exhausted by now.

Edit: the wallet does respond to command line RPC commands like getinfo and getliquidityinfo

report: nbt/usd pool seems to be working.

Thanks, I can confirm that the orders are in the books of the exchanges, but liquidity broadcast to Nu network is still broken (see error above). Doubt that the payout will work, but we will see that in 12 h or so.
@Nagalim, @woolly_sammoth Any ideas what might cause this liquidity broadcast issue all of the sudden?