[Passed] LiquidBits term 7 grant (updated) - Automatic Liquidity Pool (ALP)

nbt/usd on ccedk: i have been getting 0.00% rate for 2-3 days and have stopped my bot. there is 2nbt on the buy side since maybe yesterday.

Sorry for that. I have been seeing a number of different issues which seems to be related to Cloudflare affecting Poloniex. And the bots are still not working properly, which is most likely related to the newly introduced nud v2.11. Nud v2.11 came into play because of liquidity broadcasting issues.

Will restore a backup with nud 2.03 and see if we can get things working properly again.
Will have an outage for potentially 2-3 hour or longer depending on success of restore.

1 Like

Restore done. Bittrex and Poloniex bots are back online, CCEDK bots working.
However, still facing the liquidity issue (Failed to process info) which also means no payouts for CCEDK bots until solved. Tried the repairwallets and checkwallets and all returning true. Just reverted back to an old chain which is now synchronising. Still facing the error…

This is a new issue which I haven’t encountered before. Possibly something with RPC connection, but nothing has changed. Running out of time here, will look into it tomorrow again.


The server crashed with a new type of error in threading.py, the Python code. Will go back further with the backup and not run apt-get, as that is the only newly introduced code, possibly some updates with python. Will attend to this in next 12h.

I’m unable to even start server.py at the moment as it just stalls. Situation is serious indeed.
Poloniex and Bittrex wall are therefore not supported by LiquidBits.

1 Like

Have gone back to a 2 weeks old backup. Replaced the walletB with an even older backup as it showed a different balance after being syncronised despite the keys were the same. Can’t explain this. Balances of both wallets are now the same. Restarted the server and the same error:

NuRPC: unable to send liquidity: failed to process info.

still continues.

The server now runs without recent Python updates, but is still not broadcasting liquidity properly. Orders have been placed on all exchanges and rewards are calculated, but there is a high chance that it fails again in the next 12 hours or that there won’t be a payout because of the liquidity error. This based on experience earlier this week.

It appears that there is something strange with RPC connection, but is unclear why that is suddenly occurring as nothing has changed in the wallet or the application code.

Any suggestions on what might be going on are more than welcome as my options are exhausted by now.

Edit: the wallet does respond to command line RPC commands like getinfo and getliquidityinfo

report: nbt/usd pool seems to be working.

Thanks, I can confirm that the orders are in the books of the exchanges, but liquidity broadcast to Nu network is still broken (see error above). Doubt that the payout will work, but we will see that in 12 h or so.
@Nagalim, @woolly_sammoth Any ideas what might cause this liquidity broadcast issue all of the sudden?

Can you manually submit liquidity using rpc?

Good one, but it appears not to be the wallet or an expired grant address. Just successfully set the buy and sell on 9.99 for the broadcasting address B954pkUEdkeT1G5Lq14Cisij5no3RVxHYe.

Payout failed, but credit file has been created. That means I can do a manual payout. Will have it accumulate for a few days and than do a payout.

Somehow information is broadcast by the ALP software with incorrect strings or messages not acceptable to the Nu client, but I can’t get my finger on it. What would have changed in the last fortnight? Maybe I can ask Creon to assist if we are running out of ideas.

Having spend a signifcant number of hours on solving this puzzle I think I have found the issue.
In the wallet appears to be an amount (1910.5972) which doesn’t have confirmation and is not supposed to be there. Initially this was in another address and this address was the first in the wallet which the ALP server doesn’t like. I moved the funds which resulted in another unconfirmed transaction. After that I run checkwallet which fixed at least part of the issue by recovering 342.9129.

However I’m still stuck with the unconfirmed part even after the checkwallet and repairwallet return “true”. Will restart LiquidBits and see whether it will start doing automatic payouts. When successfull I will do manual payouts of the last two days.

Issue resolved, liquidity is broadcast right now.

Thank you for your patience.


Automatic payout failed, Replacing the wallet and restarting server in another attempt to fix the payouts this time.

Thank YOU for taking care of all these.

Anything interesting to share about the cause?

I’m still puzzled about how this happened. It looks like that somehow a transaction (change?) without a confirmation was created which can’t be resolved with repairwallet. The balance in the wallet is 1910.5972 too high. Moving the funds to another wallet seems the only solution as the ALP software refuses to payout with this wallet at all. In a few hours time it will hopefully be confirmed with an automatic payout from another wallet, if not I’m going to re download the entire blockchain as a last resort.

Hopefully in the future we will look back at these bad old days with amusement.

1 Like

This did occur so all problems appear to be solved now. I will manually transfer about 3 days of backpay in 12 hours or so.

1 Like

I will temporarily stop the liquidity provision on CCEDK as the coin have been in maintenance and trading is not possible


I understand the issue has been solved and the NBT pairs are back in service on CCEDK.
Will start the pool in the next 12-16 hours. Assuming the new grant passes, I will start run under terms of term 8.

1 Like

CCEDK pairs are available again. LiquidBits server online with terms from term 8 grant.

Further updates and announcement regarding LiquidBits server will be in the term 8 thread.