Parked NuBits Stuck in Wallet


#1

I have Parked NuBits Stuck in my wallet for 7 months when it was supposed to be released 4 months ago.

Please Help!

Capture|690x80


#2

Are you sure your wallet is fully synchronised with the blockchain? Just ensure you have the big green tick at the bottom on the right.


#3

I have 2 connections but the synchronization is stuck.
Should it debug the wallet or a clean reinstall


#4

Have you already tried starting and stopping it?

Else stop the wallet and make sure you have a good backup of the wallet.dat and then clear out the folder with the blockchain files. You can either try to download them via a magnet link/torrent. That would be a bit faster. Check out this thread: Download NuBits blockchain (bootstrap)

Or just start over again and let the client sync from scratch. This may take a few days. Once you have a tick, stop the wallet, replace the newly created wallet.dat in your folder with the backup you made earlier and restart. You will then see all your funds appear.


#5

I already start a new wallet from scratch with the “bootstrap” and my wallet.dat but i see several files like walletB.dat, should i keep or remove these files ?


#6

Please secure both WalletB.dat and WalletS.dat. You need to backup them (ideally after you have encrypted your wallets) and later replace them back after the wallet has synced entirely. The other wallets are for other currencies you can’t obtain yet, so you can leave those as they contain no funds anyway.

The syncing should not be hindered by your wallet files, it is mainly a precaution while you are about to delete the blockchain files. It is easy to delete all and there is no way to retrieve your funds when your wallet files are gone.

Please let us know whether the syncing actually happens or not after you have replaced the downloaded blockchain files and you started the wallet. After that it can still take several hours until it has fully synced. If it doesn’t sync, please ensure your internet connection is working. The next step would be adding nodes in the config file.


#7

I did a full clean wallet reinstall, it took 5 days to fully sync even with the bootstrap. I used the single “wallet.dat” backup file that was created in August last year. I do not have the “WalletB.dat and WalletS.dat”. However i do not see my funds, all balance are zero. Any advice ?


#8

The wallet daemon is expecting a walletB.dat file. If it doesn’t find one it will create an empty one which is why you can’t see your coins.
Try using your wallet.dat backup file but rename it to walletB.dat in the data directory and it should work.


#9

Thanks. I see my funds now.
Next time should i backup all .dat files in addition of the wallet.dat ?


#10

Glad that worked and you can see your NuBits.

The different wallets are used for the different Nu currencies:
walletB.dat for USNBT
walletS.dat for NuShares
walletE.dat for EUNBT
walletY.dat for CNNBT
walletX.dat for XNBT

There will be new wallets added for the KRW and JPY Nubits that are being developed currently too.

You only need to back up the wallet files for the currencies you own. Generally it’s a safer bet just to back them all up though as then you can;t get it wrong accidentally.


#11

Thanks for prompt support.