Nubits wallet crashing as coins unpark

I have 5 NBT parked for 11.4 days and they should unpark several hours ago. Now when I open my wallet, I see these coin still parked, with 0.0 days left. After about 15 seconds after the gui shows, the wallet hangs.

The last line in debug.log:

Found unparkable output: hash=40af2…

version vo.3-beta on 32bit win7.

Have you tried v0.4.2?
…oh I see that 0.4.4 is the current version…

Can you backup your wallet files and then try downloading the latest version of the client from the website?

Just a reminder – if you are running a wallet client with a version from before launch, please upgrade ASAP to v0.4.4 (available from

As always, please back up your wallets (walletS.dat and walletB.dat) before upgrading, just to be on the safe side.

Thanks guys. Just downloaded 0.4.4, uninstalled the pre-release version, and copied nu.exe over. Wow new color scheme!
Sadly the wallet still hangs with the same error message. Parked coins are still parked :frowning:
I removed the binary and did a setup installation. Got the same results.

This is the nu.conf




Alright try this. Shutdown Nu. In your data directory rename addr.dat to addr.old. Also remove all of the addnode=xxx from your conf file. Start up Nu again.

Just tried it. Didn’t help. I have shutdown nu, deleted addr.dat, database/log* blk* and restarted nu. While nu is sync’ing, I have dumped priv keys just in case the wallet with parked nubits will never work again. (I have tried nu with new
empty wallet. it works)

Did you import the private key to get it to work?

I find as long as I don’t import the unpark address the wallet works. The coins are still in parked status, with 0.0 min left. Maybe it has something to do with these coin being parked with the 0.3.0 wallet? How do I get the parked coins back?

Discussing this with the team. Save the problem wallet for now.

The history of the coins are:

  1. a number of NBT goes to address A
  2. 5 NBT from address A is parked for 11.4 days, the unpark address being B
  3. 11.4 days is up. Coins are still parked. Wallet hangs if it has B, even B is the only address it has. It doesn’t if only has A.

I will save the wallet with A and B and use a new wallet without A or B.

@sigmike is looking into this further.

Thanks. Let me know if I can help.

What error message do you get?

Try running unpark in the debug console of the NuBits wallet.

What error message do you get?

The same one in the top message above.

I am waiting for the wallet to sync before trying unpark. It has been stuck at block 40975 for almost an hour now (8 connections).
btw unparking is not automatic?

Yes it’s automatic. It’s done at random interval. The unpark command triggers the same process in a slightly different way so the result may help me understand what’s going on. Because I haven’t found a way to reproduce the problem yet.

OK the wallet is sync’ed. 1) I first tried with wallet with only address A. I get


from the unpark command on the console.

On the main GUI of the wallet the “parked” line still has 5. Pressing the park button of the wallet I see an empty display.

  1. Then I restarted the wallet with the a wallet that has addresses A and B, disconnected from the LAN, and imported private key of address B. Then I reconnect with the internet, a few seconds later the wallet hangs. This shows that it is impossible to run unpark with a wallet that has address B while online.

  2. Kill the wallet process. I unconnected the LAN, start a wallet with address A, import address B. I can see parked coins in "park’ GUI. Run unpark. The wallet immediately hangs.

Hope this helps. I can send you the keys. They have only $5 so it’s no big deal.

Have you tried the same process with he daemon? It’s a few extra steps but I can assist through chat in trying it.