NuBits v5.2.0 Release


#22

Not likely, I’ve dedicated a full 16 gigs for wallet and it only used about 2gb when it crashed. Tried on both the 32 and 64bit version. The 64bit has access to the full 16gb’s of memory. Does the same thing from a fresh sync or from the provided blockchain. Bare in mind that the wallet has been tested on windows 7, 8, and 10. 64 bit.

I currently run 36 different wallets on the servers and the Nu wallet is the only one that is crashing on all windows versions with fresh sync and also from a downloaded blockchain.


#23

It may also be because Nu tries to allocate an absurd amount of memory, but that doesn’t happen on any of my systems.

Does anyone else have the same problem (Nu crashing with a “bad alloc” error while there is plenty of memory)?

Did you use the same wallet file during your tests? Can you try with a fresh wallet?


#24

Tried it both ways. Same and new wallet.

Did you get the full chain on windows? If so can you upload the full chain? Let me know which windows version and how much memory.


#25

Yes I let the client download the chain entirely from other nodes (it took a few days).

https://bitbucket.org/JordanLeePeershares/nubit/downloads/Nu%20blockchain%202017-09-17.torrent

It’s from the VM I described above: Windows 7 64 bits with 8 GB of RAM. But these files should work on any system.


#26

Which version of the NU (32/64 bits) wallet are your running? Just tried tried the 64bit nu wallet and it hasn’t crashed yet at 98% sync. If the 64bit nu wallet fully syncs then it may indicate an issue with the 32bit nu build…

Update: OK, it seems the NU 64bit version has fully synced and working. No crashes so far. So it seems like there’s an issue with the 32bit NU wallet.


#27

64 bits.

I just learned that on Windows, a 32 bits applications needs a special flag at compile time to get 4 GB of memory, otherwise it gets a 2 GB limit. I don’t think we provide such a flag, so the 32 bits Windows version certainly cannot work with our current chain. I won’t build it in future releases.


#28

I’ve removed the 32 bits folder in the Windows zip release file and updated the sha256sum in the first post.


#29

the 32bit version bearly works on my win7 laptop these days, using 1.6G mem .


#30

I’ve installed the 64 bit version, but it still installs to C:\Program Files (x86)\Nu , not really a problem, but I’ve always wondered why this is


#31

It would be nice if the “repairwallet” function actually works to clear out the orphans. This would help a bit in keeping the wallet clean.


#32

It’s very likely that the Nu NSR wallet is having some issues on Nova Exchange. Might have crashed.