Nu terminal crash

I copied the walletS.dat and walletB.dat plus nu.conf from one computer to another, shortly after launching, I got this error. :frowning:

My platform is windows7 64bit and 2 way Xeon X5660.

I wonder why installation directory is “C:\Program Files (x86)\Nu\nu.exe” since I used “nu-0.3.0-win-gitian\64\Nu-0.3.0-win-setup.exe” and it seems a 64bit version setup.

When I run nu.exe from \nu-0.3.0-win-gitian\64 rather than from C:\Program Files (x86)\Nu\nu.exe, the problem disapears.

Perhaps the C:\Program Files (x86)\Nu\nu.exe calls a 32bit DLL?

Not sure what is happening, sounds odd. Can only tell that it does work for me on a Window7 64bit installation. Haven’t tried the copy trick across computers though. Did manage to copy to another directory and start another instance from there (not at the same time).

One for the devs I guess.

@Sabreiib can you send me your log file? You can email it to

Hi all!
Seems like I entered the nu community :wink:
I have not yet read the whitepaper, but tried to play with the nu application.
And I encounter similar problems. I have not installed Nu and simply tried to run te nu.exe (on Win7-64). I tried both the 32 bit version and the 64 bit version. They crash. I deleted the block chain and tried it again. As soon as seven thousend something blocks are downloaded, nu.exe crashes. After a restart of nu.exe some more blocks might get downloaded before it crashes again. debug.log doesn’t look helping, but I can email it anyway if you want.

Thank you for the follow-up, MoD, and welcome. We’ll make sure this gets the attention that it needs. Can you please send CG (email above) your log files?

Can you also confirm for me what version of Nu you are running? Is it v0.3.0 or v0.4.0? Thank you.

Everything works fine for me, though I am using v0.3.0, where would v0.4.0 be located?

it is 0.3.0 - and like I already emailed Coingame: nu.exe suddenly startet to work properly when I ran it once more to make a screenshot of the crash…
The good news is that it works.
The bad news is that I don’t know why it didn’t from the start.
I already emailed Coingame the debug.log, but I doubt there can be found useful information. The last entry before the last crash (when I zipped the debug.log) did only show (from my point of view) unsuspicious entries:
“Added 5 addresses from 6 tried, 46 new
trying connection lastseen=-364138.7hrs
connection timeout
trying connection lastseen=-22.3hrs
Added time data, samples 7, offset -64 (-1 minutes)
nTimeOffset = -64 (-1 minutes)
Moving to tried
version message: version 3, blocks=13798
getblocks -1 to 00000000000000000000 limit 500
received block 6cd10ac38edba03a67af
connection timeout
trying connection lastseen=-364138.7hrs

When it finally finished downloading the block chain I encountered repeatedly states of “not responding” but without more crashes.

I hope you can derive anything useful from that.
If you have more questions, please ask :wink: