[Mandatory Upgrade] All minters need to upgrade to B&C Exchange 4.0.1

Right. I will modify today my data feeds and remove all votes enabled by version 4.

That incident reminds me that “nothing” is to double-check in quality assurance, indeed.

@cryptog, as I said above, after I upgraded to v4.0.1 on March 31st I was still minting blocks until April 4th. I was following your data feed (I originally thought it was Cybnate’s feed, but it was yours) and it turns out that the day I stopped minting blocks is the same day you started voting for assets and other things, April 4th…


Oh, they are considered by the clients, but not by the network…
Or the clients withhold minting until the protocol supports these votes.

Based on the feedback from



it’s quite clear that users who configured votes (manually or by data feed) can’t mint blocks.
I can’t tell whether the network rejects them or the client doesn’t even try to create them.
The debug.log might tell.

@Sabreiib, @Sentinelrv, @crypto_coiner are there any error messages in the debug.log file?

Removing the votes from the data feeds seems to move the network into the right direction - maybe it’s only fluctuation:

    "2.0" : {
        "blocks" : 1137,
        "block_percentage" : 56.85,
        "switch_to_date_time" : ""
    "4.0" : {
        "blocks" : 863,
        "block_percentage" : 43.15,
        "switch_to_date_time" : ""

At block 402,085: 43.35%

1 Like

Dont have access to my machine right now - will get to it in about 10h.

@masterOfDisaster add me to the list of cryptog subscribers that weren’t minting.

last block minted April 06, 2016 (I subscribed to his feed around that time)

"errors" : "Unable to set key from data feed signature"

I have no experience with data feeds, but does that not sound like there’s something wrong with the feed itself and not the content it provides?

Btw. - the protocol 4.0 rate is increasing; this are the results from every quarter of an hour of the last two hours:

    "blocks" : 402124,
        "block_percentage" : 43.55,
    "blocks" : 402134,
        "block_percentage" : 43.45,
    "blocks" : 402145,
        "block_percentage" : 43.3,
    "blocks" : 402157,
        "block_percentage" : 43.45,
    "blocks" : 402161,
        "block_percentage" : 43.5,
    "blocks" : 402165,
        "block_percentage" : 43.65,
    "blocks" : 402174,
        "block_percentage" : 43.7,
    "blocks" : 402188,
        "block_percentage" : 43.75,
    "blocks" : 402197,
        "block_percentage" : 43.7,

The 4.0 percentage is slowly increasing.


Just got home from work and noticed this same error message at the bottom of my client.

Sorry. It seems that putting null as values for signerreward caused an issue.
Fixed here
@crypto_coiner , @Sentinelrv , @willy can you check if the error is gone.

It is gone here.
Sorry for the inconvenience.

1 Like

Got this error several times:

ERROR: CreateCoinStake : generated vote is invalid

when I was not able to mint

43.1%, still rising :smile:

That seems to work

1 Like

There might still be something else at play. I’m only seeing 6 connections. Yesterday I had 7, it should be 8.
Anyone else having a number lower than 8 connections during a sustained period?

Have no trouble with connections with other clients, like Nu or Peercoin

Try to delete you address.dat, and restart.

1 Like

I have 8.

I have 8 now after deleting addr.dat. Problem solved for me.

Update from me.

Yes, it’s gone, thanks.

Before you posted this I deleted the B&C client completely from my computer including this file and let it resync. Before I was getting only 3 connections, but now I have 8. I also removed the new voting options in my data feed. I did all this before I went to bed.

When I woke up I checked it and I still hadn’t minted any blocks. I ended up completely removing my data feed and it still didn’t mint. After some further digging, I realized that even though I removed the new voting options from my feed, in the reputation and asset sections, voting was still configured from the feed I had previously removed. Removing the feed had not removed the votes for reputation and assets. Once I removed all the voting manually, I immediately minted a new block. So it seems to be minting normally now.

When I come back from work, is there anything else you guys want me to try? While removing the new voting options worked to get me minting again, I hear that @Cybnate and @Yurizhai are having no problem minting with the new options.

@Cybnate, I was reading your post in your data feed thread…

The thing that stuck out to me was that you were only voting for assets and not reputation related stuff. Have you ever tried minting with reputation voting options set?

We all had a problem minting with @cryptog’s feed. Nobody seemed to have a problem with your feed though. One difference I can see is that @cryptog had votes set for both assets and reputation while you only had votes set for assets. Maybe the reputation votes are preventing people from minting? Have you ever minted a block with reputation votes set?

When I get home I’d like to try voting for both assets and reputation at the same time and then only with assets and no reputation and see if either mints blocks on my client.

1 Like

Quick update. I got home from work about an hour ago, and found my client continued to mint 21 times throughout the day with no problems. As an experiment, I setup asset voting using the same selections that Cybnate is using while leaving the reputation section blank. I was able to mint a block with asset info selected!

Now I’m going to remove the asset voting info, so it’s blank and instead fill out the reputation voting info that I previously had in there and see if I mint a block then. I’ll give it to tomorrow morning when I wake up.


Thanks for your tests.
They very much help narrowing down the reason for the problem!

1 Like