Made a transaction while catching up with blockchain


I made a NBT transaction while Linux 64bit Nu-Qt v2.0.3-beta was catching up. When it caught up I saw another transaction to the same address and the same amount appear. That was wired. The latter got confirmed (…) and the first one is unconfirmed.

Now I made another transaction spending the rest on my NBT and it would not confirm. Please help.

1 Like

Ok, so I dunno why it happened, but I have a bad fix for you:
Backup your wallet, dump your private keys (copy them down to a word processor or something), close nud, delete your wallet (OMG make sure you backed it up), restart nud, reload in your private keys one by one into a new wallet. Tada, fresh wallet.

There’s prolly a much better way to do this, but I’m pretty sure this will fix your problem.

Do you know how to find the data directory? If so there’s a file called debug.log. Can you try to search for errors in the log? It may give you more information.

The debug.log gets rewritten after every restart AFAK. Unfortunately mine is empty now. Doing the bad fix now.

It should not re-write every time. The log is appended to after each start. If you have an empty log file then that could be a sign of some issues with your configuration.

1 Like

Hey sorry. I removed your last post to hide the URL. The log file can sometimes contain persoanl information such as IP addresses and minting addresses. I don’t know if you cared to reveal any of that but I figured it was better to inform you first and remove the info.

I have the log and i’ll take a look for errors.

1 Like

Alright. Thanks. Hope you guys will fix the bug I stumbled upon.

There’s a couple of errors indicating you were trying to use inputs that had already been spent. Were you trying to submit a raw transaction to the network?

No. Like I said - I made a transaction while still catching up with blockchain. Saw a popup in notification area. When catching up was complete I saw another popup. Went to see the transaction list and saw two transaction for the same amount and the same address. The second got confirmed - the first one did not. And I could not spend any NBT after that. Just checked debug.log myself - too bad the moment of troublesome transaction creation is not there. Got truncated I guess. Hope you could replicate than anyway.

More info - I was catching up on about a day worth of blocks and all the incoming transactions were already there.

Can you try running the -rescan parameter when you start the wallet? I think it may be confused about its own transaction histories.

./nu -rescan

It will take some time upon startup for it to go through the entire blockchain, but it should square away any inconsistencies.


Not on my current setup. I decided to rename my ~/.nu and do it all over again. I did tried that though and it did not helped. Tried issuing ‘repairwallet’ command at debug window’s console as well. It said it found and fixed inconsistencies at the time but that did not remedied the situation too.

I think you want to run the rescan after repair wallet. Maybe that’s how you did it though. I’m surprised the rescan did not help. The client looks like its choking because of trying to use inputs that have already been spent. Maybe @Nagalim’s solution will work.

It’s the result of transaction malleability:

Alright, all my NBT are back under control, thank you everyone. I will be wise enough not to do anything while still syncing the blockchain.