Download NuBits blockchain (bootstrap)


If you want to understand more about nubits and nushares, please visit the white paper.


Sorry to hear your struggles. Doing what I can for you. I had it downloaded in about 8-10 hours recently. As mentioned it may be a problem with your provider either throttling traffic or having a congested network.
I agree that things need to be made more user friendly especially for new users. We should review that on the list of priorities.

I did some instructions here: Download NuBits blockchain (bootstrap)


I produced the following error when I:

Waited for first 10,000 blocks to come in and waited for nu to disappear from my processes list before I:

  • deleted block 1, block index, database folder and dblog, pasted blockindex, block 1
  • deleted entire folder, pasted blockindex, block 1, wallets and addr.dat
  • deleted entire folder only pasted blockindex, block 1
  • deleted only block 1, blockindex, pasted new block 1, block index

From db.log

file unknown has LSN 1302/985781, past end of log at 1/327
Commonly caused by moving a database from one database environment
to another without clearing the database LSNs, or by removing all of
the log files from a database environment
__db_meta_setup: [$HOME]/.nu/blkindex.dat: unexpected file type or format
Database handles still open at environment close
Open database handle: addr.dat/main

From debug.log

ERROR: CheckProofOfStake() : INFO: check kernel failed on coinstake … … …
WARNING: ProcessBlock(): check proof-of-stake failed for block … … …

I was going to wait 30 minutes with nu open, 30 minutes nu closed, then I screwed up halfway through. So instead, I dropped in my own blockindex and block 1 that I synced up to todays blocks and everything worked fine. Those blocks were downloaded via 5.02, and I have my “detach databases at shutdown” setting checked.

Maybe the bug in the Sept 17th torrent is the running os (Im running linux for testing) or the database wasnt detached before shutdown?
Im willing to make new torrent file and seed, if thats the case.

@woczqhas Perhaps that will help with the 3 month blockchain download time. I do apologize for being a bit callous. I think Im hangry [hungry anger].


I know the August one was created fine and worked, It is also smaller and therefore faster because it was tarballed (zipped) perhaps the September was not created properly. It is the first time I’ve heard issues with it but maybe not many users have tried or just failed and gave up without posting here. I’m seeding both and I know there is at least one other seeding.


@woczqhas @Phoenix @jooize
Ive made a new one with my working indexes. Ill keep it seeding whenever I can (I have a laptop) and whoever has privileges to the website and bitbucket can add it and reseed. Ive zipped it with linux as a .zip (so it should work) but if windows users cant unzip it, Im happy to switch over to windows and make one that linux will also extract. I recommend that whenever there is an update, admins create a new torrent file, compress it and bug test it. Perhaps add it to the wallet page, and seed though the website itself along with instructions (feel free to copy mine below).

Magnet link (copy/paste into browser address bar with a torrent software installed).


After downloading, unzip the file, back up your entire nu folder in case accidents happen, and while nu is not running (verify in the running processes list), copy both files (blockindex.dat and blk0001.dat) into the nu folder (in linux thats home folder, .nu folder, or in Windows under %appdata). When prompted, replace the files (did you back the folder up? If need be, do so! Especially if you have nubits or nushares in your wallet). Run nu and check the last accepted block (under the help menu, debug window) to verify you have downloaded the most recent check point of Nu’s blockchain.


I’m downloading it and checking it out. Once I believe it is ok I will help seeding it.
Just noticed that you only joined the forum 6 hours ago.


I joined to contribute more this round. I once joined during the major peg loss to inform people of the importance of the peg and to inform admins of the importance of community. My user name was CommunityObserver. I lost my password long ago. Someone else made a user name of ConfusedObserver. That isnt me. I also forgot to make the “these arent official files” disclaimer but I forgot. Thanks for verifying and not blindly trusting my torrent, in the spirit of nakamoto. :smiley:


Just extracted the files posted by @CommunityObserver1 without a problem after a 2 hour download. I’ve copied the files (and scanned for viruses) into a newly configured client. It all seems to work.
I’m also seeding the file so a download of those files should be quick assuming your provider allows you the bandwidth.


Hopefully this will save others the enormous amount of time wastage and frustration I’ve experienced this week. My sync is currently at 96% and the price has sunk so I might as well wait it out. Thank you both for your efforts.


I recommend keeping a back up copy on an external, selecting detach databases at shutdown setting in the client (so you can move the files to another computer, or upgrade the client without issues), and opening up nubits to sync about once a week, even when you have no nubits. Its what I do for all the blockchains that I use.

Parked NuBits Stuck in Wallet

Thank you, @CommunityObserver1! Do you know if we can verify that @CommunityObserver is your old account so you can continue using it? PM me.

Can we have confirmations that these files work with each platform? Windows, Linux, macOS. I noticed when the blockchain began being recorded into blk0002.dat, that blk0001.dat wasn’t the exact same size on Linux and macOS.

Magnet link for latest blockchain snapshot



I confirmed it working on Ubuntu Linux earlier in the thread.