Cointoolkit FLOT guide and changelog

Great! Thank you!
I will create some bookmarks :wink:

Even better, also redirect to HTTPS automatically. A friend told me that’s possible with JavaScript.

1 Like

It would be convenience to have a broadcast button on the verify page.

1 Like

@jooize, redirection to https forced now.

@mhps button added.

@FLOT members, the floating point issue on the fee calculation is now fixed.


Thank you very much!

Now when I open cointoolkit front page the change mode drop down menu is empty. Same when choose new address from the page, etc. When open the redeem script links here (old and new addresses) I only see the front page of cointoolkit with the same problem. I am using firefox.

I don’t have the problem with my local copy for testing my modified known-pubkeys.js on Jan 25th, before pull request.

I can’t reproduce here. Do you have java script enabled? Could you press F12 -> click console and check if there is any error? (marked in red, there should be a few warnings in yellow)

I have NoScript plugin but for cointoolkit it is not blocking anything. cointoolkit had worked before.

after yellow and red warnings there is this at the end

NS_ERROR_UNEXPECTED: cointoolkit.js:4:0

clicking on cointookit.js:4:0 gives the source code withthis highlighted

    window.location.protocol = "https:";

if this is reelevant:
the page is not opened in securemode (http, not https) and in the console there was a red warning

Password fields present on an insecure (http://) page. This is a security risk that allows user login credentials to be stolen.

Seems like a bug in the https redirection, change the http:// for https:// in the URL and it should work. Will push a fix..
Edit: Fixed

1 Like

I can confirm it is fixed.

Before anyone notify this as a bug, I have added support for NBT, NSR, BKC and BKS transaction broadcasting, but the API calls on the explorer are currently offline, so that part will not work for now.

Anyway, expect TX broadcasting from Cointoolkit soon!


Please update this status when available!

BTW thanks for the POWERFUL ability to create Hierarchical Deterministic (BTC, NBT, NSR, BKS, BKC) addresses by brainwallet input method <-- “Hierarchical Deterministic Brainwallet”

No words to describe it: Outstanding!

Change request: please add a “copy to clipbpard” button under the “Shareable verification link” URL box. pressing control-c didn’t work again probably due to tired fingers the other day.

BKS and BKC broadcasting should work now. Please test and report!


feature suggestion:
add a verify button by the new tx generation box, to verify it w/o copy-paste.

I wrote a guide for making multisig transactions with Cointoolkit.

There’s also some suggested improvements at the bottom.


I really tried broadcasting signed BKS transaction with Cointoolkit three times without success.

After all procedures (getting inputs, creating tx, verifying, signing) going OK, when trying to broadcast the status “Please wait, loading…” took forever. I’ve checked and nothing really happened.

I even tried creating simpler tx removing some inputs but no success.

I’ve also tried broadcasting through Official Client pasting the signed tx (sendrawtransaction cmd) but I got the “TX decode failed (code -22)” error everytime.

Bitcoin tx works smoothly! I only need internet connection in order to get inputs and broadcast tx (using your hosted version of Cointoolkit). Everything else (verifying and signing) can be done from an offline/downloaded version of Cointoolkit.

One more situation: when creating a tx and requesting the inputs, the
inputs for BKS (NBT, NSR, BKC too) are in the format 0.0000 (four
digits after dot) instead of eight digits after dot. That may get people
a little confused about the address’ real amount. Bitcoin’s inputs show every satoshi precisely.

BTW once BKS/BKC and NBT/NSR are fully working (broadcasting issue solved), count on me to support Cointoolkit to be promoted at the Nubits official website. It will be a must there!

Please allow me to take a look at that BKS issue, create a new clean address from a priv key to share with me, and a really small test transaction on BKS, send it by PM so I can find the problem.

That the way those coins works, they are only divisible to 4 digits. It must be documented somewhere.


Test performed. Sent to you by PM.

NP, I’ve got so much used to BTC’s eight digits satoshi standard…

That’s it.

@ttutdxh notice for this from Cointoolkit

Uncaught TypeError: Cannot read property ‘listUnspent’ of undefined Failed to load resource: the server responded with a status of 404 (Not Found) Failed to load resource: the server responded with a status of 522 (OK)
?mode=peercoin&address=53210234139729dd413c84a71a0bfd6f236790be861b37311cef3240277c940e4b0c07210312…:1 XMLHttpRequest cannot load No ‘Access-Control-Allow-Origin’ header is present on the requested resource. Origin ‘’ is therefore not allowed access. The response had HTTP status code 522.

this site down for some days