Account balances show in debug console but not in overview



I ran into the problem of wallet stuck at a block and will not download more blocks. I tried re-download from scratch and copy over my old wallet files. With my old Nu data, if I run “listaccounts” from debug console, I have following accounts with non-zero balances:

“a”: balanceX
"b": balanceY
"": balanceZ

balanceZ is much smaller than X and Y, and account name is a blank string. Is this the minted balance ?

Anyway, after I copied wallet data to new Nu data directory, the overview shows zero balance. However, in debug console, “listaccounts” shows:

“a”: balanceX
"b": balanceY
"": 0

What’s going on and how can I fix this ? Thanks.


The blank string account is the default account so is normal to see.
I’d say that the balanceZ is in blocks that aren’t yet downloaded in the second example.
Which version of the Nu client are you running?


You’re right about balanceZ in blocks not downloaded yet, I’m starting to see balanceZ values.

However, while I can see all 3 balances show in debug console (listaccounts command), the main program windows (overview, send) display zero balance. I do see my transactions in the transaction list.

I’m using client v5.0.1-beta.


Is the blockchain fully downloaded? I’m not sure the balance in the main UI will show as available until it is as it doesn’t know if it’s about to download a block that sends the whole balance away.